CVE-2007-1358

Loading...

General

Score:2.6/10.0
Severity:Low
Category:XSS Injection
Exploit:Available

Impact Metrics

Confidentiality:None
Integrity:Partial
Availability:None

Exploitability Metrics

Access Vector:Network
Access Complexity:High
Authentication:None

Relative vulnerabilities

CVE-2002-1148, CVE-2002-1394, CVE-2002-2006, CVE-2003-0866, CVE-2004-0687, CVE-2004-0688, CVE-2004-0885, CVE-2004-0914, CVE-2005-0605, CVE-2005-2090, CVE-2005-3164, CVE-2005-3510, CVE-2005-3964, CVE-2005-4838, CVE-2006-0254, CVE-2006-0898, CVE-2006-1329, CVE-2006-3835, CVE-2006-3918, CVE-2006-5752, CVE-2006-7195, CVE-2006-7196, CVE-2006-7197, CVE-2007-0243, CVE-2007-0450, CVE-2007-1349, CVE-2007-1355, CVE-2007-1860, CVE-2007-1863, CVE-2007-2435, CVE-2007-2449, CVE-2007-2450, CVE-2007-2788, CVE-2007-2789, CVE-2007-3304, CVE-2007-3382, CVE-2007-3385, CVE-2007-3847, CVE-2007-4465, CVE-2007-5000, CVE-2007-5116, CVE-2007-5333, CVE-2007-5461, CVE-2007-5961, CVE-2007-6306, CVE-2007-6388, CVE-2008-0005, CVE-2008-0128, CVE-2008-1232, CVE-2008-1927, CVE-2008-2364, CVE-2008-2369, CVE-2008-2370, CVE-2008-2939, CVE-2008-5515, CVE-2009-0023, CVE-2009-0033, CVE-2009-0580, CVE-2009-1891, CVE-2009-1955, CVE-2009-1956, CVE-2009-2412, CVE-2009-3094, CVE-2009-3095, CVE-2009-4901, CVE-2009-4902, CVE-2010-0407, CVE-2010-0434

Published on 10/05/07 - Updated on 25/03/19

Description

Cross-site scripting (XSS) vulnerability in certain applications using Apache Tomcat 4.0.0 through 4.0.6 and 4.1.0 through 4.1.34 allows remote attackers to inject arbitrary web script or HTML via crafted "Accept-Language headers that do not conform to RFC 2616".

Category: XSS Injection

CWE-79 (Cross-Site Scripting (XSS))
The software does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users.

Security Notices

US National Vulnerability DatabaseCVE-2007-1358
Agence Nationale de la Sécurité des Systèmes d'Information CERTA-2007-AVI-340, CERTA-2008-AVI-349, CERTA-2009-AVI-032
Redhat RHSA-2008:0261, RHSA-2008:0524, RHSA-2008:0630, RHSA-2010:0602
Renater 2008/VULN259

Exploits

SecurityFocusBID-24524, BID-25159

Relative technologies

VendorProduct
apachetomcat

Share this vulnerability with:

Twitter Facebook LinkedIn Mail