CVE-2009-4214

Loading...

General

Score:4.3/10.0
Severity:Low
Category:XSS Injection
Exploit:Available

Impact Metrics

Confidentiality:None
Integrity:Partial
Availability:None

Exploitability Metrics

Access Vector:Network
Access Complexity:Medium
Authentication:None

Relative vulnerabilities

CVE-2003-0063, CVE-2006-1329, CVE-2008-0564, CVE-2008-0888, CVE-2008-2712, CVE-2008-4101, CVE-2008-4456, CVE-2008-5302, CVE-2008-5303, CVE-2008-5515, CVE-2008-7247, CVE-2009-0033, CVE-2009-0037, CVE-2009-0316, CVE-2009-0580, CVE-2009-0688, CVE-2009-0689, CVE-2009-0781, CVE-2009-0783, CVE-2009-1904, CVE-2009-2042, CVE-2009-2417, CVE-2009-2422, CVE-2009-2446, CVE-2009-2632, CVE-2009-2693, CVE-2009-2801, CVE-2009-2901, CVE-2009-2902, CVE-2009-2906, CVE-2009-3009, CVE-2009-3086, CVE-2009-3095, CVE-2009-3557, CVE-2009-3558, CVE-2009-3559, CVE-2009-4017, CVE-2009-4019, CVE-2009-4030, CVE-2009-4142, CVE-2009-4143, CVE-2010-0041, CVE-2010-0042, CVE-2010-0043, CVE-2010-0055, CVE-2010-0056, CVE-2010-0057, CVE-2010-0058, CVE-2010-0059, CVE-2010-0060, CVE-2010-0062, CVE-2010-0063, CVE-2010-0064, CVE-2010-0065, CVE-2010-0393, CVE-2010-0497, CVE-2010-0498, CVE-2010-0500, CVE-2010-0501, CVE-2010-0502, CVE-2010-0503, CVE-2010-0504, CVE-2010-0505, CVE-2010-0506, CVE-2010-0507, CVE-2010-0508, CVE-2010-0509, CVE-2010-0510, CVE-2010-0511, CVE-2010-0512, CVE-2010-0513, CVE-2010-0514, CVE-2010-0515, CVE-2010-0516, CVE-2010-0517, CVE-2010-0518, CVE-2010-0519, CVE-2010-0520, CVE-2010-0521, CVE-2010-0522, CVE-2010-0523, CVE-2010-0524, CVE-2010-0525, CVE-2010-0526, CVE-2010-0533, CVE-2010-0534, CVE-2010-0535, CVE-2010-0537, CVE-2011-2930, CVE-2011-2931, CVE-2011-3186

Published on 07/12/09 - Updated on 08/08/19

Description

Cross-site scripting (XSS) vulnerability in the strip_tags function in Ruby on Rails before 2.2.s, and 2.3.x before 2.3.5, allows remote attackers to inject arbitrary web script or HTML via vectors involving non-printing ASCII characters, related to HTML::Tokenizer and actionpack/lib/action_controller/vendor/html-scanner/html/node.rb.

Category: XSS Injection

CWE-79 (Cross-Site Scripting (XSS))
The software does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users.

Security Notices

US National Vulnerability DatabaseCVE-2009-4214
Agence Nationale de la Sécurité des Systèmes d'Information CERTA-2010-AVI-143
Debian DSA-2260-1, DSA-2301-1
Renater 2010/VULN102

Exploits

SecurityFocusBID-37142

Relative technologies

VendorProduct
rubyonrailsrails
rubyonrailsruby_on_rails

Share this vulnerability with:

Twitter Facebook LinkedIn Mail