CVE-2007-3227

Loading...

Général

Score :4.3/10.0
Sévérité :Faible
Catégorie :Injection XSS
Exploit :Disponible

Métriques d'impact

Confidentialité :Aucun
Intégrité :Partiel
Disponibilité :Aucun

Métriques d'exploitabilité

Vecteur d'Accès :Réseau
Complexité d'Accès :Moyenne
Authentification :Aucune

Vulnérabilités associées

CVE-2007-5379, CVE-2007-5380

Publiée le 15/06/07 - Mise à jour le 08/08/19

Description

Cross-site scripting (XSS) vulnerability in the to_json (ActiveRecord::Base#to_json) function in Ruby on Rails before edge 9606 allows remote attackers to inject arbitrary web script via the input values.

Catégorie : Injection XSS

CWE-79 (Injection de code indirecte (XSS))
Le logiciel ne neutralise pas ou neutralise mal une entrée contrôlable par un utilisateur avant qu'elle ne soit retournée et utilisée comme une page Web qui est servie à d'autres utilisateurs.

Avis de sécurité

US National Vulnerability DatabaseCVE-2007-3227
Renater 2007/VULN450

Exploits

Exploit-DBEDB-30089
SecurityFocusBID-24161

Technologies associées

FournisseurProduit
rubyonrailsrails

Partagez cette vulnérabilité avec :

Twitter Facebook LinkedIn Mail